"Target did not respond" when trying to flash the alif_kws project

Hello there,
Not sure it’s the right place, but I’ve been struggling with this issue for a while now…
I’ve built the ml projects in the repo, and now trying to flash it into the device and run it.
It worked for me for a few days, but from a certain point on, I get the following:

Writing MRAM with parameters:
Device Part# E3 (AE302F80F55D5AE) - 5.5 MRAM / 13.5 SRAM - Rev: A1
- Available MRAM: 5767168 bytes
[INFO] Burning: <some_app>.bin 0x8027b120
[INFO] baud rate  100000
[INFO] dynamic baud rate change  Enabled
[INFO] COM9 open Serial port success
[ERROR] Target did not respond

I tried to run “recovery” and the different tools a couple of times, all of that shows that error.

Is someone familiar with such error? Is there a way to solve this?
Thanks in advance

Hi @danielya,

Thanks for raising the issue. I believe the application you are running is from a fork of Arm’s ML Embedded Eval Kit. We don’t support the E3/5/7 platforms in our vanilla repository, so I suspect you are building using alif_ml-embedded-evaluation-kit. If so, you should request help from the maintainers by creating a GitHub issue for that repository.

Hope this helps.